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IITCA INTERMEDIATE EXCEL HANDBOOK 

 

 

2.1 Let’s Start with Excel Charts 

 

So, in Excel we have charts which is a visual representation of data 

from a worksheet that can bring more understanding to the data than 

just looking at the numbers. A chart is often called a graph 

(although graph is a representation of mathematical function). 

A chart is a powerful tool that allows you to visually display data in 

a variety of different chart formats such as Bar, Column, Pie, Line, 

Area, Doughnut, Scatter, Surface, or Radar charts. With Excel, it is easy to create a chart. 
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2.2 Create an Excel Chart 

 

 

To start making your chart, highlight the BBC1 programs, and the viewing figures. If you 
have just finished the sorting section, this data should still be highlighted, and look like 
this: 

 

With your programs and the viewing figures highlighted, do this: 
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• From the tabs on the Excel Ribbon, click on Insert 
• Locate the Charts panel. It looks like this in Excel 2007: 

 

In later versions of Excel, the Charts panel looks like this: 

 

For this first one, we'll create a Column Chart. So, in Excel 2007, click the down arrow on 
the Column item of the Chart Panel. You'll see a list of available charts to choose from. 
Select the first one, the chart highlighted below (2D Column): 
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The Column drop down list in later versions of Excel looks like this: 

 

When you make your selection, a new chart appears on the same spreadsheet that you 
have open. The chart should look the same as the one at the top if this page. 

But notice that the Excel Ribbon has changed. The design menu is selected, along with 
options for Chart Layouts: 

 

In Excel 2013 to 2016, you'll see these layouts on the left, in the Chart Layouts panel, 
under Quick Layouts: 

 

Also on the Design Ribbon, you'll see options for Chart styles: 
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You'll see how to use these later. For now, your chart may be covering your viewing 
figures. In the next part, we'll see how to move and resize a chart. 

2.3 Move and Resize your Chart 

In the image below, our chart is overlapping the ITV data. To move it, hold your mouse 
over the chart until your cursor changes shape: (We found that the best place for your 
mouse is over the dots in Excel 2007, as we had problems moving a chart when the 
cursor was anywhere else! Moving charts in later versions of Excel is easier.) 

 

Press and hold down the mouse button when your cursor looks like the one in the image 
above, and then drag your chart to a new location. In the image below, we've placed the 
chart below the data. 
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You can also place your chart in a different worksheet. To do this in Excel 2007, right click 
anywhere on your chart. From the menu, select Move Chart: 
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In Excel 2010 to 2016 there is a Location panel to the right of Chart Styles. Click 
the Move Chart item: 

 

In all versions, you'll then get a dialogue box popping up: 

 

If you want your chart in a new worksheet, select the first option. Then delete the text 
"Chart1" from the textbox, and then type a name of your own. 

If you look along the bottom of Excel, you'll see Sheet1, Sheet2, and Sheet3. Your data 
is in Sheet1. If you click the drop-down list to the right of Object in on the dialogue box 
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above, you'll see the other worksheets you have open. You can select one from the list 
and click OK. But for this first chart, leave it in Sheet1. 
 

How to Resize an Excel Chart 

You can resize a chart, and any elements on it, by moving your mouse over the sizing 
handles. For the chart itself, the sizing handles are the dots around the edges of the chart 
in Excel 2007: 

 

In later versions, the sizing handles are white squares: 

 

When your mouse changes shape to a double-headed arrow, hold down your left mouse 
button. Then drag to a new location. You can resize using the corners, or the edges. 

2.4 Chart Styles and Layouts 

You can easily change the Style of your chart. If you can't see the Styles, click anywhere 
on your chart to select it, and you should see the Ribbon change. The Styles will look like 
this in Excel 2007: 
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In newer versions of Excel, your Chart Styles will look like this: 

 

Click on any chart style, and your chart will change. To see more styles, click the arrows 
to the right of the Chart Styles panel: 

 

You'll then see a drop-down sheet of new styles (Excel 2007): 
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And here's the Styles in Excel 2013 to 2016: 

 

Work your way through the Styles, and click on each one in turn. Watch what happens to 
your chart when you select a style. 

Chart Layouts 

You can also change the layout of your chart in the same way. Locate the Chart 
Layout panel on the Design tab of the Excel Ribbon bar. It looks like this in Excel 2007: 

 

In newer versions of Excel, you may have to click the Quick Layout option on the Chart 
Layouts panel: 

 

Click the down arrow to the right of the Chart Layouts panel to see the available layouts 
you can choose from: 

 

Again, click on each one in turn and see what happens to your chart. In the image below, 
we've gone for Layout 10: 
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Changing the Chart Type - 2D Bar Charts 

You can change the type of chart, as well. Instead of having a 2D column chart, as above, 
you can have a 2D bar chart. To change the chart type, locate the Type panel on the 
Excel Ribbon bar (you need to have your chart selected to see it): 

         

Then click Change Chart Type. You'll see a dialogue box appear. This one is from Excel 
2007: 

 

The dialogue box looks slightly different in Excel 2013: 
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Excel 2016 has some new chart types: 

 

In the image above, Microsoft have added six new charts: Treemap, Sunburst, Histogram, 
Box and Whisker, Waterfall, and Funnel. If you have this version of Excel, click each one 
in turn to see what they look like. For example, here's the what the Funnel chart looks 
like: 
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But select Bar from the list on the left of the dialogue box, and click on the first Bar chart 
(Clustered Bar). Click OK to see your chart change: 
 

 

You can experiment with the types of chart in the dialogue box. But reset it to Bar chart, 
as above. 

2.5 Chart Titles and Series Titles 

 
Once you have your chart in place, there are plenty of formatting options in Excel. In the 
chart above, for example, the title says, "Chart Title". And there's a not terribly descriptive 
orange square that says "Series 1" (your bars may be blue). We'll see how to change that 
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in a moment. But first, the Chart Title. (If you don't have a title in Excel 2010, select the 
first layout in the Chart Layouts panel.) 
 

How to Change the Chart Title 

To change the title of your chart, click on the title to select it: 

 

The circles surrounding the title tell you that it is selected. Once the title is selected, click 
on the letter "C" of Chart. Hold your left mouse button down and highlight the two words, 
as in the image below: 

 

Once your title is highlighted, you can change it by simply typing a new one: 

 

While the title is highlighted, you can select a different font and font size, if you want (on 
the Home panel in the Excel Ribbon at the top.) 

To deselect the title, click anywhere outside of it. 

Formatting a Series Title 

To change the Series 1 text on the Chart heading to something more descriptive, select 
the title as you did above: 

 

Make sure the circles are there, and then right click. You should see the following menu 
appear in Excel 2007: 
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Click on "Edit data source". Alternatively, click the Edit data source item on 
the Data panel on the Excel 2007 Ribbon: 

 

For Excel 2010 and 2016 users, your menu looks like this: 

 

The item to click on the menu above will say Select Data instead of Edit Data Source. 
In both versions you should then see the following dialogue box appear. 
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The Chart Data Range at the top of the dialogue box is highlighting the cells A5 to B14. 
This is the data we selected for the chart. Below this there is an area for Legend Entries 
(Series) and Horizontal Axis Labels. We'll see more of these later. For now, though, we 
just want to change Series 1 into something more descriptive. 
 
So, click on Series 1 to highlight it. Then click the Edit button, as in the image below: 

 

When you click the Edit button, you'll see a new dialogue box appear - Edit Series. It 
should look like this: 
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Notice the cells being referenced in the Series name area. They are cells A5 to B14. 
These same cells are also highlighted on the spreadsheet: 

 

Click on the BBC title instead, the one on Row 3 above. Your Edit Series dialogue box 
will have changed. The Series Name area will now say A3 (amongst all those dollars): 

 

Click OK to get back to your Edit Data Source dialogue box. The Series legend will now 
say BBC: 
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Click OK to return to your spreadsheet. But look what's happened to the chart. The Series 
1 has gone. Next to the orange square, we now have BBC 1: 

 

We'll meet these boxes again when we create a chart from scratch. For now, let's see 
some more formatting option you can do with an Excel chart. 

2.6 Chart Layout Panel in Excel  

In the previous part of this lesson on charts, you saw how to format a chart with various 
dialogue boxes. 
 
You can also format your charts using the menu items on the Excel Ribbon bar, at the top 
of the screen. With your chart selected, click the Layout menu (Not Excel 2013 to 2016. 
See below for your Layout options). You should see this: 
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The Layout menu is a bit big for this page, so we've split it in two. But the chart Layout 
panel is split into many different sections (six in our version), and allows you to change 
the information in the chart. 

For Excel 2013 to 2016 users, your Layout options are on the Design tab still, on the far 
left, just under the File menu: 

 

Click Add Chart Element to see the following drop-down list: 

 

For all versions of Excel, The first thing you may want to do is to give your chart a name. 
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To change the name of your chart in Excel versions 2007 and 2010, locate 
the Properties panel on the Layout menu: 

 

Highlight the default name in the textbox and type a new one: 

 

If you now click away from your chart, and then click back on it, you'll notice the name of 
the chart change: 

 

For Excel 2013 to 2016 users, locate the Name box just below Chart Layouts: 

 

Highlight the default Chart 1. Type a new name (BBC 1) and press enter: 
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The Labels Panel in Excel 2007/2010 

The Labels panel on the Layout menu lets you format the titles and legends on your chart. 
Here it is: 

 

Or this for Excel 2013 to 2016 users: 

 

The first one is Chart Title. Click the arrow to see the options: 
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Click each item on the menu in turn to see what they do. Then click More Title Options. 
The following dialogue box will appear (Excel 2010 has more options. Excel 2013to 2016 
users, see below for your options.): 

 

As you can see, there are options to change the Fill, Line, Line Style, Shadow, 3-D format, 
and Alignment. Play around with the options on the dialogue box to see what they do. 
The only thing you're changing here is the Chart Tile. Click Close when you're done. If 
you don't like what you see, click the undo arrow at the top of Excel. 

Formatting Chart Titles in Excel 2013 to 2016 

Excel 2013 and 2016 users won't see a dialogue box. Instead, you'll see a panel appear 
on the right of the screen. This one: 
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Click an arrow to see further options. Here are the options for Fill: 

 

You can also click the icons at the top. There are three of them: a paint bucket, an 
Hexagon, and a resize symbol. 

Click the Hexagon and you'll see these options: 
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Click the Resize symbol and the options will change to these: 

 

As well as the three symbols, you can click the Text Options, just to the right of Title 
Options at the top. You'll then see even more options, this time to change the text itself: 
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Play around with all and see how they work. 

Change the Axis Title in Excel 2007/2010 

The next item on the Labels panel is the Axis Title. Click the down arrow to see the 
options: 

 

At the moment, our chart has no Axis Title. It just has numbers running across the bottom. 
Someone looking at the chart won't know what the numbers represent. Here's what our 
Chart looks like at the moment: 
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To add an Axis title in Excel 2007 and 2010, click on Primary Horizontal Axis Title. From 
the sub menu, click Title Below Axis. 

 

In Excel 2013 and 2016, select Primary Horizontal on the Axis Titles menu of Add 
Chart Elements: 
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When you click Title Below Axis or Primary Horizontal, a new title will be added to the 
chart: 

 

Highlight the default text, and type your own: 

 

Click away from the chart to see what it looks like: 

 

We now have some explanation for what the numbers represent. You can add a Vertical 
Axis, as well. Click on Primary Vertical Axis Title and see how it works. 

Chart Legend 

The Chart's Legend is this one: 
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At the moment, our Legend is on the right of the chart. But you can move this. Click 
the Legend item on the Layout panel to see the various options: 
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Click an option on the menu and watch what happens to your Legend. You should see it 
move around your chart. 

Adding Data Labels to an Excel Chart 

A Data Label is information overlaid on the chart bars. In our chart below, we have 
numbers overlaid on the orange bars: 

 

You can format these Data Labels. Click the Data Labels item on the Labels panel to 
see the following options: 
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The one wat we have at the moment is Inside Edge. Click on Outside End and your 
Data Labels will look like this: 

 

You can also see the options if you click More Data Label Options from the menu. You'll 
then see this dialogue box (In Excel 2013 and 2016, again, you won't see a dialogue box. 
Instead, you'll see the Format panel appear on the right of your screen. The same options 
as below will be available, however.): 
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Again, play around with the options to see what they do. The first two, Label Options and 
Number, are the ones you'll probably use most often. 

2.7 The Format Chart Panel 

The Format panels allow you to create some great looking charts with just a few mouse 
clicks. 
 
Click on your chart to select it, and then click the Format menu at the top of the Excel 
Ribbon. You should see this long menu, split in two here (In newer versions of Excel, you 
may also have an Insert Shapes area): 

 

 

Using the various Format Panels on the Excel Ribbon, we'll format our chart from this: 
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To this: 

 

OK, it may look a bit gaudy! But at least it's lively. You can create a chart like this quite 
easily: 

• First, click on your chart to highlight it 
• Click the Format menu on the Excel Ribbon 
• Locate the Shape Styles panel: 
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Click the down arrow on the right of the panel to see the available styles (there might not 
be so many styles in Excel 2013, so you may have to select a different color): 

 

When you move your mouse over a style, your chart will change automatically. But you 
won't be able to see the full effect until you click away from the chart. We went for Style 
28, the one that's highlighted in the image above. You get the rounded corners, the drop 
shadow and the color fill. 

Create your own Chart Style in Excel 

You can create all that yourself, though. If you want to create your own style, try the 
following: 

Fill your chart with a color by clicking the down arrow on Shape Fill on the Shape Styles 
panel: 
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Select a color from the list. Or click "More Fill Colors". Once your chart has a color, you 
can liven it up a bit. 

Still on the same menu, click on Gradient. The sub menu appears: 

 

We went for one of the Dark Variations. 
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Next, you can spruce up the text on your chart. Locate the WordArt Styles panel: 

 

Click the Text Fill button to see the available colours: 

 

Once you have the chart background and text formatted the way you want it, you can add 
some rounded corners, and a bit of drop shadow. You can apply both of those from the 
Format Chart Area dialogue box. Here's how. 

To bring up the Format Chart Area dialogue box, click the Format Selection button on 
the Current Selection panel: 

 

You'll then see the following dialogue box appear (If you're using Excel 2013 and 2016, 
you'll see a panel appear on the right of your screen instead of a dialogue box): 
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To get rounded corners, click on Line in Excel 2007. You'll then see the following options: 

 

In Excel 2010, you'll have a Border Styles menu on the left. Click that to see the 
Rounded Corners option. For Excel 2013 and 2016, click the Border category to expand 
it. The Rounded Corners options is at the bottom: 
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Put a tick in the box for Rounded Corners. 

To get a Shadow for your chart, click the Shadow option on the left of your dialogue box. 
The options will change to these: 
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For Excel 2013 and 2016 users, click the Hexagon symbol at the top, just to the right of 
the paint bucket: 

 

Click the Presets button to see a list of pre-made shadows: 
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Select the one you like. Then click Close on the dialogue box. Your chart will then have 
rounded corners and a drop shadow. 

 

OK, you should now a very smart chart. Playing around with the various options on the 
Format Chart Area dialogue box can really bring an Excel chart to life! 
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8 Create a Pie Chart in Excel 

Pie charts are quite easy to create in Excel. In case you're not sure what a Pie Chart is, 
here's the basic one you'll be creating. Later, you'll add some formatting to this: 

 

To make a start, you need to highlight some data. If you've been following along with 
the previous tutorials, then you'll have some viewing figures data. You've created a 2D 
chart with the BBC data. This time we'll use the ITV data. If you don't have this data, 
create the following simple spreadsheet. The cells to use are D4 to E14: 
 

 

• Click inside cell E4 and change "Millions" to ITV, if you already have the data from a previous 
lesson 

• Highlight the cells D4 to E14 
• Click the Insert menu at the top of Excel 
• Locate the Chart panel, and the Pie item: 
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In Excel 2013 and 2016, the Pie chart is harder to spot. But it's highlighted in green in the 
image below: 

 

Click the down arrow and select the first Pie chart: 
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• A new Pie chart is inserted 
• Move your new pie chart by dragging it to a new location 
• Notice how all the segments of the pie chart are the same colour in Excel 2007: 

 

To get assorted colors, make sure that your chart is selected and locate the Chart 
Style panel: 

 

Click the down arrow to the right of the Chart Style panel to reveal the available styles : 
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We've gone for the second one, Style two. If you haven't got this style, select a similar 
one, such as style 4 in Excel 2013 and Excel 2016. The chart will then look like this (your 
labels may well be at the bottom, though, depending on which version of Excel you have): 

 

But it looks pretty good for just a few mouse clicks! We can still do a bit more to it, though. 
In the next part, you'll see how to add the viewing figures to the pie chart segments. 
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2.9 Add Labels to a Pie Chart 

At the moment, though, there's no information about what each segment represents. 
We're going to add the numbers from our ITV viewing figures. These ones: 

 

To add the numbers from our E column (the viewing figures), left click on the pie chart 
itself to select it: 

 

The chart is selected when you can see all those blue circles surrounding it. Now right 
click the chart. You should get the following menu: 
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From the menu, select Add Data Labels. New data labels will then appear on your chart: 

 

The values are in percentages in Excel 2007, however. To change this, right click your 
chart again. From the menu, select Format Data Labels: 
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When you click Format Data Labels, you should get a dialogue box. This one: 

 

If there's a tick in Percentage, untick this and select Value: 

 

Your chart will then have the correct numbers: 
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Overall, the chart looks OK. But we can add some formatting to it. in the next part, you'll 
see how to format each individual segment of the Pie Chart. We'll change the color of one 
segment, and separate it. 

2.10 Format Pie Chart Segments 

 

You can change the color of each slice of your pie chart, and even move a slice. Let's 
change the colors first. 

Change the Color of a Pie Chart Segment 

Left click on the pie chart itself to select it: 

 

It is selected when you can see those round handles. Now left click on one of the 
segments to select just that individual slice. It's a little bit tricky, but if you do it right your 
pie chart should look like this: 
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In the image above, only the 10.99 segment is selected. You should see round circles 
surrounding just that segment. Now right click your segment and, from the menu that 
appears, select Format Data Point: 

 

You should see the following dialogue box appears in Excel 2007: 
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You'll see a panel appear on the right of your screen in Excel 2013 and 2016. 

 

Click the paint bucket icon at the top, then click to expand the Fill option. Select Solid fill, 
and select a color from the dropdown list: 

 

In Excel 2007, click on Fill from the options on the left. The dialogue box changes to this: 
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There are quite a lot of options to experiment with. But select the Solid Fill option: 

 

Now click the color picker, and choose a new color for the segment: 
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We've gone for a dark orange color, but select any color you like. 

Move a Pie Chart Segment in Excel 

To move the slice that you've just colored, click back on Series Options from the options 
on the left: 

 

In Excel 2013 and 2016, click the three bars icon: 
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Set the Point Explosion slider to about 30% 

 

Now click the Close button. Your chart should look something like this one: 
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Change the rest of the slices in exactly the same way. You can format the rest of the chart 
exactly like you did for the Bar chart. But it looks quite impressive as it is! 
 

2.11 Create a 2D Line Chart in Excel 

For this last chart, we'll compare the viewing figures of BBC1 and ITV. A line chart is 
better for this type of data. The chart we'll create looks like this: 
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We're comparing how many hours per week a person watches BBC1 with how many 
hours they watch ITV. You'll need some data, of course. Start a new spreadsheet and 
enter the same data as below: 

 

Once you have your spreadsheet data, highlight the cells A3 to H5. Now 
click Insert from the Ribbon bar in Excel 2007 and 2010. Locate the Charts panel, and 

click on Other Charts. From the menu, select All Chart Types (In Excel 2013 and 2016, 
there is no Other Charts option. See below for what you should do): 

 

When you click All Chart Types, you'll get a dialogue box popping up: 
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From the dialogue box, the left hand side shows all the chart templates. Click on Line. 
Select the first Line chart, the one highlighted in the image above. Click OK and Excel 
will insert your chart. It should look like this: 

 

In Excel 2013 and 2016, click the Recommended Charts item instead of Other Charts: 
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You'll then see a dialogue box appear. Click on All Charts: 

 

Select Line from the list on the left to see all the available line charts (2016 users will 
have more charts on the list). Select the first one. Your charts will then look like this: 
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For all users, the chart looks a bit plain, at the moment. You can change the colour of 
the lines for BBC and ITV. Locate the Chart Styles panel on the Designmenu: 

 

Click the down arrow on the right of the Chart Styles panel to reveal the available styles: 

 

We've gone for the first one, top left. When you select a style, your chart will change: 
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The lines are more distinct now. The dates at the bottom don't look too impressive, 
though! In the next part, you'll see how to format the dates on the bottom Axis. 

 

 

2.12 Format your Axis Titles 
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To format the dates on the bottom Axis, click on them with your left mouse button. With 
the dates Axis selected, right click. You should see this menu: 

 

Select Format Axis from the menu, and you'll see the following dialogue box appear in 
Excel 2007 and 2010: 

 

Excel 2013 and 2016 users will see a panel appear on the right of the screen, instead of 
a dialogue box: 
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Under Axis Type, select Text Axis: 
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Your dates should end up in the middle. (Our version of Excel was a little buggy. We had 
to click Date axis, then click back on Text axis to get the dates in the middle.) 

 

 

Adding an Axis Title 

To add an Axis label at the top of your chart, if you have Excel 2007 or Excel 2010, click 
the Layout menu at the top of Excel. Then locate the Labels panel: 

 

Click on Chart Title. From the menu, select Above Chart: 

 

If you have Excel 2013 and 2016, however, stay on the Design Ribbon and locate 
the Chart Layouts panel on the left, just under the File menu. Click Add Chart Element, 
then Chart Title > Above Chart: 
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You will then see a default title appear at the top of the chart. Highlight the text, and type 
a title of your own: 

 

  

Add a Left Axis 

We now need to add an Axis for the numbers running up the left of the chart. The numbers 
are the hours per week that people watch each channel - 0 to 6. 
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From the Labels menu still, select Axis Titles > Primary Vertical Axis Title > Rotated 
Title: 

 

 

(Excel 2013 and 2016 users won't have Rotated Title option - the title will roate by itself.) 
This will add a title like the following one: 
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Highlight the default title and type Hours. You can move the title to the left by clicking and 
dragging. This is a little tricky, though! Use the Zoom tool at the bottom of Excel to zoom 
in on your target: 

 

 

Move the Axis in to position: 

 

When you're done, your chart should now look like this one: 
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Or this: 

 

Spruce it up a bit by adding a bit of fill color, rounded edges, and shadow 



  

IITCA INTERMEDIATE EXCEL HANDBOOK 66 

 

 

And that's it for line charts. If you've been following along from the beginning, you should 
now have some impressive Excel chart skills. 

In the next part, we'll take a look at how to predict future values with Excel charts. 

 

 

2.13 Predict the future with a Trendline Chart 

Excel can help you make predictions about future values, or help you spot a linear trend. 
What we'll do in this section is set up something called a Trendline. We'll use an X, Y 
Scatter chart for this. We'll take a look at future income predictions based on what was 
earned in previous years. If you're a bit confused, don't worry: it will all become clear as 
we go along. 

Type the following headings into cells A1 to C1: 

Year 
Years since 2006 
Income 

Format the cells, if you prefer. Your spreadsheet will then look like this: 
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Enter the years 2006 to 2019 into cells A2 to A15: 

 

As an X axis for our chart, we can have the years since 2006. These values will be used 
in a later formula. In Cells B2 to B15 enter the values 0 to 13: 
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We now need some income values for the years 2006 to 2013. This is income that has 
actually been earned, rather than income that might be earned in the future. We'll then 
use this hard data to predict future values. Enter some income values, then, into cells C2 
to C9. We made up the following values: 

 

We're now ready to insert an X, Y Scatter chart. 
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Highlight the cells B1 to C9: 

 

This will be the data for our chart. 

From the top of Excel, click on the Insert ribbon. From the Charts panel, locate and click 
on the Scatter charter icon. The icon looks like this: 

 

Select the first item to get a chart with just dots: 
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(If you can't see the icon above, click on Recommended Charts. Switch to the All 
Charts tab, then select X Y Scatter). 
A new chart will then appear on your spreadsheet. It should look like this: 

 

The figures along the bottom, the X Axis, are our years since 2006. The figures on the Y 
Axis are our income values. The first dot, the one on the far left, tells us that we made just 
over 12000 at Year 0, (Year 0 is 2006). At Year 1 (2007) we made just under 16000. At 
Year 2 (2008) we made just over 14000, and so on. 

All these dots seem to form a loose line going up from the left. You could add a line 
yourself using the Shapes item on the Illustrations panel. What you'll then have done is 
to create a linear regression. 

Rather than add the line ourselves, however, Excel can add the line for us. Not only that, 
it can give us the formula it used to create the line. We can use that formula to predict 
future incomes. 

Click on your chart to highlight it. You should see three icons appear on the right, in Excel 
2013 and 2016. (See below for Excel 2007 and Excel 2010.) Click on the Plus symbol, 
and put a check in the box for Trendline: 
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When you check Trendline, you should see a line appear on your chart: 

 

To get the line in Excel 2007 and 2010, select your chart then click on the Layout tab. 
From the Analysis panel, click the Trendline option. From the Trendline menu, 
select Linear Trendline. 
The line represents Excel's best fit for a linear regression. It's trying to put as many as 
the dots as it can as close to the line as possible. 

To see the equation Excel used, click on the Plus symbol again (Excel 2013 and Excel 
2016). Then click on the arrow to the right of Trendline. A new menu appears. 
Select More Options at the bottom: 
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You should see a panel open on the right of Excel, like the one in the next image. 

For Excel 2007 and 2010 users, Click the Layout tab again. Then click the Trendline on 
the Analysis panel. From the Trendline menu this time, select More Trendline Options. 
You'll then see a dialogue box with options the same as the ones in the image below. 
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The Trendline option we've chosen is Linear. Have a look at the bottom, and check the 
box next to Display Equation on chart. 
When you check the box, you should the following equation appear on your chart: 

y = 564.88x + 13604 
This is something called the Slope-Intercept Equation. If you remember you Math lessons 
from school, the equation is usually written like this (the "b" at the end may be a different 
letter, depending on where in the world you were taught Math): 

y = mx + b 
In this formula, the letter "m" is the slope (gradient) of the line, and the letter "b" is the first 
value on the y axis. The x is a value on the X-Axis. Once you have the slope of the line, 
a value for the X-Axis, and the starting point of the line, you can extend the line, and work 
out other values on it. This will be the letter "y" in the equation. 

Excel has already worked out two values for us, the "m" and the "b". The "m" (the slope) 
is 564.88 and the "b" is an income value of 13604. 

To work out the y values we just need an "x". The "x" for us will be those "Years since 
2006" in our B column. 

Click inside cell C10 on your spreadsheet, then. Enter the following: 

=564.88 * B10 + 13604 
Press the enter key and you should find that Excel comes up with a value of 18123.04. 
This is the predicated income for the year 2014. Use Autofill for the cells B11 to B15. The 
rest of the predicted values will then be filled in: 
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So, Excel is predicting we'll earn 18123.04 in 2014. By 2019, it's predicting we'll earn 
20947.44. 

 

 

2.14 Sparkline Charts 
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The graph in the cell A8 shows the scores that Lisa achieved in her tests. You can quickly 
see that Lisa's scores are going up all the time, with no dips. 

To add Sparklines to your own spreadsheets, start with some data. (You need more than 
one value, otherwise you'll just have a dot.) In a new Excel spreadsheet, type the following 
exam scores: 

 

Change the height of row 8 to create more room for the Sparklines. To do this, you can 
simply move your mouse to just below the number 8 on the left of Excel. When your 
mouse pointer changes shape, hold down the left mouse button. Keep it held down and 
drag to a new height. 

If you want an exact value for the height, click inside of any cell on row 8. Locate 
the Cells panel on the Home ribbon at the top of Excel: 

 

From the Cells panel, click on Format. From the Format menu, select Row Height: 
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When you select Row Height, you'll see a small dialogue box appear. Type in a new value 
for the height and click OK: 

 

Row 8 on your spreadsheet should now look like this: 
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Adding a Sparkline to a Spreadsheet Cell 

To add a Sparkline, click inside of cell A8. Now select the Insert ribbon from the top of 
Excel. From the Insert ribbon, locate the Sparklines panel: 

 

You can see that there are three options: Line, Column, and Win/Loss. The first two are 
the most used options. Click on Line and you'll see a dialogue box appear. This one: 

 

The first text box is where you specify your Data Range. Click inside this box and enter 
A1:A7. For the second text box, Location Range, you specify where on your spreadsheet 
you want your Sparkline to appear. We want the Sparkline to appear in cell A8. The dollar 
signs before the A and 8 mean it will be an Absolute cell reference, as opposed to a 
Relative cell reference. If you leave the Location Range box blank then your Sparkline 
will appear in the currently selected cell. 
Your Create Sparklines dialogue box should look like this: 
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Don't worry if your Location Range text box is blank, though. As long as your Data Range 
box is filled in you can click OK. 

When you do click OK, your A8 cell will look like this: 

 

You can use AutoFill for the other exam scores. Move your mouse pointer to the bottom 
right of cell A8 until the pointer turns into a black cross. Hold down your left mouse button. 
Keep it held down and drag to cell D8. You should see all four cells fill with Sparkline 
charts: 
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Functions 

If you're trying to work out an average, you're trying to calculate what the most common 
value is. For example, if a class of eight students took exams, you may want to know what 
the average exam score was. In other words, what result most students can expect to 
get. In order to calculate an average, you'd add up all eight exam scores and divide by 
how many students took the exam. So, if the total for all eight students was 400, dividing 
by 8 would get you 50 as the average grade. If any students were below the average, you 
can tell at a glance. 

In Excel, there is an easy way to calculate the average of some numbers - just use the 
inbuilt Average function. 

Start a new spreadsheet and enter the following exams scores in cells A1 to A8, as in the 
image below: 

 

Click in cell A9, and we'll see how to use the Average function in Excel 2007. There are 
two ways we can do this. Try method 1 first. 
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Method 1 

Next to the formula bar, you'll see an FX button. This is the Formula Wizard: 

 

 

When you click the FX button, you'll see the Insert Function dialogue box appear: 

 

The Insert Function dialogue box shows a list functions. These are the just the common 
ones. To see more functions, click the drop-down list to the right of Select a category. The 
one we want is displayed under Select a function, though - Average. Click on this, and 
then click OK. 

When you click OK, another dialogue box appears. On this dialogue box, you select the 
data that you want to include in your function: 
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If you look in the Number1 box, you'll see Excel has guessed which cells we want to use 
for our Average function - A1:A8. It evens gives the answer to the Function - 6.625. 

Click OK to insert the function. 

Method 2 

The second way to enter a Function in Excel is through the panels on the Ribbon. Try 
this: 

• Click inside cell B9 on your spreadsheet. This is where we'll place the Average for the 
cells A1 to A8. 

• Click the Formulas menu at the top of Excel 
• Locate the Function Library panel. Here it is in Excel 2007 

 

And here it is in later versions: 
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As you can see, in Excel functions are split into categories. The Average function is in a 
few places. The easiest way to use Average is with AutoSum. Click the down arrow on 
AutoSum to see the following: 

 

Now click Average from the menu. Because the answer is going in cell B9, Excel doesn't 
know which cells you want to use in the function, so it can't give you a quick answer. 
AutoSum is good when the data is in the same row or column. But when it's not, you must 
tell it what to calculate. 

So, click inside cell A1 and you'll see the cell selected 
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Hold down your left mouse button over the bottom right blue square, and drag to cell A8: 

 

Excel fills in the cells for your function. Let go of the left mouse button, and then press the 
Enter key on your keyboard. The correct answer is place in cell B9: 

 

You can also find the Average function on the More Functions menu. Click Statistical, and 
you'll see it there: 
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Of course, once you know the correct function, you could simply type it all out in the 
Formula bar yourself! 

Try this exercise. 

Exercise 
You start your own online business and find that sales for the first week are these: 
Monday Rs. 120.45 
Tuesday Rs. 187.43 
Wednesday Rs. 106.87 
Thursday Rs. 143.69 
Friday Rs. 117.52 
Saturday Rs. 87.93 
Sunday Rs. 92.12 
Use a function to work out how much you earned, on average, each day. 

There are a number of different reasons why you would want a Date or Time function in a 
spreadsheet: If you're running your own company, you might want to record when an order was 
received and when it was processed. You could then calculate the difference between the two, so 
that you check how fast the orders were being processed. We'll do that now. 

The Excel Date Function 

As an example of how to use date functions in Excel, we'll construct as simple 
spreadsheets for an order form. We'll enter the date an order was taken, the date the 
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order was sent, and how long it took to be processed. So, to make a start, create the 
spreadsheet below: 

 

Click inside cell A2, and we'll enter a date. To enter a date, Click on the Formulas menu 
at the top of Excel. Then locate the Function Library panel. From the Function Library 
panel, click on Date & Time: 

 

As you can see, there's quite a lot of Date and Time functions! Click on Date from the 
menu, and you'll get the following dialogue box: 
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You're now being asked to enter a full date. 

• In the Year box, enter 2016 
• In the Month box, enter the number 4 
• In the Day box, enter the number 15 
• Click the OK button 
• Excel will enter the Date in your selected cell, A2 for us 

 

Notice the DATE Function in the Formula bar: 

=DATE(2016, 4, 15) 
Between the round brackets of DATE, the Year comes first, then the Month, then the Day. 

If you want to format your date as say Monday 15th of April, then you need to click on 
the Home tab from the Ribbon at the top of Excel. Locate the Nmumber panel, and you'll 
see Date already displayed: 
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Click the down arrow to see more options: 

 

Click the Long Date item. Or click on More at the bottom to see some more Date formats 
to choose from. Your spreadsheet will then look like this: 

 

In cell B2, under your Date Order Sent heading, enter another Date Function. This time, 
have the date read May 3, 2016: 
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In cell C2, under Time Taken, we'll work out how many days the order took to be sent 
out. 

The Days360 Function in Excel 

When you want to work out how many days there are between two dates, the function to 
use is Days360(). We want to work out how many days there are between the 15th of 
April 2016 and the 3rd of May 2016. So, click inside cell C2 and do the following: 

Click on the Formulas tab at the top of Excel. Then locate the Function Library panel. 
From the Function Library panel, click on Date & Time. From the menu, click 
on Days360(). You should see the Function Arguments dialogue box appear again. This 
time, it will look like this: 

 

The Days360 function needs a start date and an end date. You can enter your cell 
references here. So, in the Start_date box, enter A2. In the End_Date box, enter B2. If 
you enter the word True in the Method box, Excel will calculate using the European date 
system. Click OK, to return to your spreadsheet and you might see this: 
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(If your C2 cell has a lot of #### symbols in it, it means that your column is not wide 
enough. Widen the C column and they'll go away!) 

The answer we got was January 18th, 1900! The reason for such a bizarre answer is that 
we've formatted the C2 cell as a date. But the answer to the Days360 function is not a 
date - it's a number. If you have the same strange answer, then format your C2 as a 
number. Your spreadsheet will then look like ours below: 

 

So, the difference between the two dates is 18 days. 

Entering dates can be straightforward, like cells A2 and B2. But performing calculations 
with dates can be slightly more complex. To get you some more practice, here's an 
exercise. 

Exercise 
Use a Days360 function to work out how many days are left before your next birthday. 
Instead of typing out the current date in say cell A2, you can use this inbuilt function: 

=Now( ) 
The Now function doesn't need anything between the round brackets. Once you have 
today's date, you can enter your birthday in say cell B2. 

In the next part, we'll look at how to handle Time functions in Excel. 
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Time Function 

There are many ways to enter the current time in an Excel spreadsheet. Try this: 

• Click inside a blank cell on your spreadsheet 
• Click into the Formula Bar at the top 
• Type the following inbuilt function: 

= Now( ) 
Hit the enter key, and you'll get the current date and time. If you only want the time, you 
can format the cell to get rid of the date part: 

• Click on the cell that contains your Now() function 
• From the Excel menu bar, click on Home 
• Locate the Number panel, and you may see Time already set (it might say Custom in newer 

versions of Excel): 

 
• Click the down arrow to see menu options 
• From the menu, click on Time 
• Click on More to see more Time options 

Excel doesn't update the Time function every second, so it's not like a normal clock. But 
you can update the Now function to get the correct time. (Well, it's correct if your system 
clock is correct!) 

The easiest way to update the Time in Excel is to click inside the cell that holds your Time 
formula. Then, from the Formulas menu, locate the Calculation panel. 

 

 

Click the "Calculate Now" button, and Excel will update the time. 
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Excel also updates the time when you enter another calculation elsewhere in the 
spreadsheet. For example, click in any other cell on your spreadsheet. Now enter a simple 
formula like = 2 + 2. When you press the Enter key on your keyboard, Excel will update 
your time function as well. 

Financial Functions 

The Main financial function we're going to explore is called PMT( ). You use this function 
when you want to calculate things like the monthly payment amounts on a loan, or how 
much per month a mortgage will cost you. We'll use it to work out how much per month a 
loan will cost us. Here's what we'll do. 

We've decided to take out a loan of ten thousand pounds from our friendly banker. We're 
going to be paying it back over 5 years. The question is, how much per month is this going 
to cost us? 

The PMT() Function in Excel 

The PMT() function expects certain values in between its two round brackets. The values 
that go in round brackets are known as arguments. The arguments for the PMT() function 
are these: 

PMT(rate, nper, pv, fv, type) 
Only the first three are needed, and you can miss the final two out, if you like. 

We'll work out our monthly loan costs with the help of the PMT() function. First, create a 
new spreadsheet like the one below: 

 

If you look at cell B1 on the spreadsheet, you'll see a figure of Rs. 10, 000. This is the 
amount we want to borrow. The labels on Row 3 show what else we need: An interest 
rate, the number of payments we'll make over the 5 years, the present value of the loan, 
the amount we'll have to pay back each month, and the total amount paid back after 5 
years. But we only need the first three for our PMT () function. 

https://www.homeandlearn.co.uk/excel2007/excel2007s5p5.html
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In cell A4, we'll need an interest rate. In cell B4 we'll need the number of payments, and 
in cell D4 we'll need the Present Value of the loan. First is interest rate. 

Imagine that the interest rate given to us by the bank is 24 percent per year. For the PMT() 
function, we need to divide this figure by 12 (the number of months in a year) So try this: 

• Click into cell A4 on your spreadsheet 
• Enter the following formula: 

= 24% / 12 

• Hit the enter key to see the answer appear, as in the image below: 

 

Now that we have an interest rate, the next thing we need for the PMT () function is how 
many payments there are in total. We must pay something back every month for 5 years. 
Which is a simple formula. So, 

• Click into B4 on your spreadsheet and enter the following: 

= 12 * 5 
• Hit the enter key to see a figure of 60 as the answer. 

This figure of 60 is for the second argument of the PMT() function - the nper. This is just 
the number of payments. 
Now that you have a figure in cell A4 (rate), and a figure in cell B4 (nper), there's only 
one more to go - the Present Value (pv). 
The Present Value of a loan, also known as the Principal, is what the loan is worth at the 
present time. Since we haven't made any payments yet, this is just 10, 000 for us. 

• Click into cell C4 on your spreadsheet and enter the following: 

= B1 
• Hit the enter key 
• You'll see a figure of 10, 000 appear, and your spreadsheet should now look ours below: 

 



  

IITCA INTERMEDIATE EXCEL HANDBOOK 93 

 

OK, we now have all the parts for our PMT () function: a rate (A4), an nper (B4), and a pv 
(C4). Try this: 

• Click into cell D4 on your spreadsheet 
• Enter the following function: 

=PMT(A4, B4, C4) 
Hit the enter key on your keyboard, and you'll see the monthly amount appear. The figure 
you should have is -Rs. 287.68. The reason there is a minus sign before the total is 
because it's a debt: what you owe to the bank. 

But this is what your spreadsheet should look like: 

 

The only thing left to do is see how much this loan will cost us at the end of 5 years. All 
you need to do here is multiply the monthly amount in cell D4 by the number of payments 
in cell B4. Enter your formula for this in cell E4, and you spreadsheet will look like ours 
below: 

 

So, a ten thousand pounds loan, at the interest rate the bank is offering, means we'll have 
to pay back just over 17 thousand pounds over 5 years. 

Tweaking the Values 

We can change the spreadsheet slightly to give us more control. For your figure in cell 
B4, the number of payments, you entered 12 * 5. This is 12 months multiplied by 5 years. 
But what if we wanted to pay the loan back over 10 years, or 15? How much will our 
monthly payments then be? And will be the final cost of the loan? 
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Also, the interest rate seems a bit high. What if we can get a better rate elsewhere? 

By making a few changes to or spreadsheet, we can amend these values more easily. 
First, we'll need two new rows. 

Inserting New Rows in Excel 

We need to insert new rows in our spreadsheet. To insert a new row, click into cell A2. 
Then click on the Home tab at the top of Excel. Locate the Cells panel, and click 
the Insert item: 

 

 

From the Insert menu, click on Insert Sheet Rows: 

 

 

Excel will insert a new row for you. Do this again to get two blank rows. Add two new 
labels, Num of Years and Interest. Your spreadsheet sheet will then look like this: 
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Adapting the PMT Formula 

We can adapt the formulas we've entered so far, in order to make them more usable. As 
an example, we'll adapt the interest rate. 

To get the interest rate for cell A4, we entered a formula: 

= 24% / 12 
 

Instead of having the interest rate in cell A4, however, we can place it at the top, in cell 
B3 on our new Row. We can then alter the interest rate by simply typing a new one in cell 
B3. To clear all that up, try the following: 

• Click inside cell B3, which is the Interest cell in the image above 
• Click inside the formula bar 
• Type in = 24% 
• Cell B3 should now read 24.00% (In Excel 2010 and 2013 you may have to format the cell to 

a Percentage value from the Home tab then the Numeritem.) 
To change the formula for your interest rate, click inside of cell A6. Change the formula from this: 

= 24% / 12 
 

to this: 

= B3 / 12 
 

Hit the enter key on your keyboard and nothing should change on your spreadsheet. But 
the difference is that you can enter a new interest rate in cell B3, and see how this effects 
the loan amounts. Try it out by typing 23% in cell B3: 
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As you can see, the interest rate has changed to a rather long figure. But notice the 
Monthly Amount - it has gone down to Rs. 281.90. The total amount we have to pay back 
has changed, too. Play around with the interest rate in cell B3, just to get a feel for how it 
works. 

Exercise 
In cell B6 of your spreadsheet, you have the following formula: 

= 12 * 5 
This calculates the number of months for the loan. Change this formula so that the number 
of years is coming from B2. Your finished spreadsheet should look like ours below: 

 

If you play around with the values in cells B1, B2 and B3 you should be able quickly see 
the new loan repayments. 

 

The Student Averages Project 

Study the following spreadsheet: 
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The spreadsheet is the school exam marks of 8 students. A total of 8 subjects were taken. 
For this review, work out the Averages for all 8 subjects studied, which is in the K column 
above. Also, work out the Overall Averages for each student (row 11 above). 

You can then use one of the methods for working out Averages that you have explored 
earlier. You're going to be needing your completed spreadsheet in the next section - so 
don't skip it! 

 

Conditional Logic 

 

1 The IF Function 

The IF function can be quite useful in a spreadsheet. It is used when you want to test for 
more than one value. For example, has a bill been paid or not? If it has, you can deduct 
the amount from the money you have left to spend; if it hasn't, keep it on your debt list. 
Later, you'll see how to use the IF Function to grade student exam scores. If the student 
has above 80, award an A grade; if the student has below 30, award a fail grade. First, 
here's what an IF Function looks like: 

IF(logical_test, value_if_true, value_if_false,) 
The thing to note here is the three items between the round brackets of the word IF. These 
are the arguments that the IF function needs. Here's what they mean: 

logical_test 
The first argument is what you want to test for. Is the number in the cell greater than 80, 
for example? 

https://www.homeandlearn.co.uk/excel2007/excel2007s6p1.html
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value_if_true 
This is what you want to do if the answer to the first argument is YES. (Award an A grade, 
for example) 
value_if_false 
This is what you want to do if the answer to the first argument is NO. (Award a FAIL 
grade.) 
If that's not terribly clear, an example may clear things up. Open a new spreadsheet, and 
do the following: 

• Widen the B column a bit, as we'll be putting a message in cell B1 
• Now click in cell A1 and type the number 6 
• Type the following in the formula bar (The right angle bracket after A1 means "Greater Than".) 

=IF(A1 > 5, "Greater than Five", "Less than Five") 
Hit the enter key on your keyboard and your spreadsheet should look like ours below: 

 

(Make sure you have all the commas and double quotes in the correct place, otherwise 
Excel will give you an error message. That right angle bracket (> ) is known as a 
Conditional Operator. You'll meet some others shortly.) 

But what we're saying in the IF function is this: 

logical_test: Is the value in cell A1 greater than 5? 
value_if_true: If the answer is Yes, display the text "Greater than 
Five" 
value_if_false: If the answer is NO, display the text "Less than Five" 
 

So your first tell Excel what you want to check the cell for, then what you want to do if the 
answer is YES, and finally what you want to do if the answer is NO. You separate each 
part with a comma. 

Exercise Try this: 
• Click into cell A1 
• Change the 6 into a 4 
• Hit the enter key on your keyboard 

What happens? 

Exercise 
Now type the number 5 in cell A1. What happens now? 
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For the last exercise above, Excel should tell you that 5 is "Less than 5"! It does this 
because the answer to your logical test was NO. We were testing if the number in cell A1 
was greater than 5. Since 5 is not greater than 5, the answer to the question is NO. We've 
told Excel to display a message of "Less than 5", if the answer was NO. In other words, 
we didn't tell Excel what to do if the value in cell A1 was the same as 5. 

The solution to this is to use a different Conditional Operator. We used the Greater Than 
(> ) operator. Here's some more: 

<      Less Than 

>=    Greater than Or Equal To 

<=    Less than Or Equal To 

<>    Not Equal To 

For the second and third operators above, you type an angle bracket followed by the 
equals sign. There are no spaces between the two. For the final one, it's a left angle 
bracket followed by a right-angle bracket. 

So, for our exercise, the symbol we should have used was the one for Greater than Or 
Equal To. Change 
 your IF function to this and try again: 

=IF(A1 >= 5, "Greater than or Equal to Five", "Less than Five") 
Exercise 
Test the A1 cell to see if the value is less than or equal to 5. If it is, display a suitable 
message. If it's not, display the message "Greater than Five". 
 

Complex If Functions 

The If Functions you've just met are consider fairly simple ones. They can get really 
complex! 

Consider our Student Exam problem. The spreadsheet we created to track our students 
looks like this, from an earlier section: 
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However, we want to display the following grades as well: 

A If the student scores 80 or above 
B If the student scores 60 to 79 
C If the student scores 45 to 59 
D If the student scores 30 to 44 
FAIL If the student scores below 30 

With such a lot to check for, what will the IF Function look like? Here's one that works: 

=IF(B2>=80, "A", IF(B2>=60, "B", IF(B2>=45, "C", IF(B2 >=30, "D", "Fail" ) ) ) ) 
Quite long, isn't it? Look at the colours of the round brackets above, and see if you can 
match them up. What we're doing here is adding more IF Functions if the answer to the 
first question is NO. If it's YES, it will just display an "A". 

But take a look at our Student Exam spreadsheet now: 
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After the correct answer is displayed in cell B14 on the spreadsheet above, we used 
AutoFill for the rest! 

Don't worry if that long IF statement is making your brain hurt - it is quite complicated. 

In the next part, we'll look at using And and OR with IF Statements. 

 

2 Conditional Formatting in Excel 

You can use something called Conditional Formatting in your Excel spreadsheets. 
Conditional Formatting allows you to change the appearance of a cell, depending on 
certain conditions. What we'll do is to color the Overall Averages on our Student Exam 
spreadsheet, depending on the grade. Here's the spreadsheet we'll be working on. 

 

• Open up your Student Exam spreadsheet (You did complete it, didn't you?) 
• Highlight the cells with Overall Grades, which should be cells B11 to I11 

The Overall Averages range from 44 to 85. We'll color each grade, depending on a scale. 
An assorted color will apply to the following grades: 

• 50 and below 
• 51 to 60 
• 61 to 70 
• 71 to 80 
• 81 and above 

So five different bands, and a color for each. To set the Conditional Formatting in Excel, 
do the following: 

• With your Overall Averages highlighted, click on the Home menu at the top of Excel 
• on The Home ribbon, locate the Styles panel, and the Conditional Formatting item: 

https://www.homeandlearn.co.uk/excel2007/excel2007s6p2.html
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The Conditional Formatting menu gives you assorted options. The easiest one is the 
Color Scales option. Select one of these and Excel will color the cell backgrounds for you: 

 

That's not quite what we're looking for, though. We'd like to choose our own values. So, 
click on More Rules, from the Color Scales submenu. You'll see the following rather 
complex dialogue box: 
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The one we want is the second option, Format only cells that contain. This will allow 
us to set up our values. When you click this option, the dialogue box changes to this: 
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The part we're interested in is the bottom part, under the heading Edit the Rule 
Description. It says Cell Value and Between, in the drop-down boxes. These are the 
ones we want. We only need to type a value for the two boxes that are currently blank in 
the image above. We can then click the Format button to choose a color. 
So type 0 in the first box and 50 in the second one: 

 

Then click the Format button. You'll get another dialogue box popping up. This is just the 
Format Cells one though. You've met this before. Click on the Fill tab and choose a colour. 
Click OK and you should see something like this under Edit the Rule Description: 

 

The Preview is showing the color we picked. So, we've said, "If the Cell Value is between 
0 and 50 then color the cell Red". 
 
Click OK on this dialogue box to get back to Excel. You should find that one of the cells 
has turned red. To format the rest of the cells, click on Conditional Formatting on the 
Styles panel again. From the menu, click on Manage Rules: 
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You'll get yet another complex dialogue box popping up! This one: 

 

Our first rule is already there - Cell Value Between. The only thing we're doing here is 
adding New Rules, like the one we've just set up. Click the New Rule button then. You'll 
see the exact same dialogue boxes you used to set up the first rule. Set a new color for 
the next scores - 51 to 60. Choose a color, and keep clicking OK until you get back to the 
Rules Manager dialogue box. It should now look something like this one: 
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We now must color in our range. Do the rest of the scores, choosing a color for each. The 
scores are these, remember: 

• 50 and below 
• 51 to 60 
• 61 to 70 
• 71 to 80 
• 81 and above 

When you've done them all, your dialogue box should have five colors: 
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The colors above are entirely arbitrary, and you don't have to select the same ones we 
did. The point is to have an assorted color for each range of scores. But click OK when 
you're done. Your Overall Averages will then look something like this: 

 

Formatting your spreadsheet in this way allows you to see at a glance relevant 
information. In the spreadsheet above, it's obvious who's failing - just look for the red 
cells! 

 

3 CountIF 

Another useful function that uses Conditional Logic is CountIF. This one is 
straightforward. As its name suggests, it counts things! But it counts things IF a condition 
is met. For example, keep a count of how many students have an A Grade. 

To get you started with this function, we'll use our Student Grade spreadsheet and count 
how many students have a score of 70 or above. First, add the following label to your 
spreadsheet: 

 

https://www.homeandlearn.co.uk/excel2007/excel2007s6p3.html
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As you can see, we've put our new label at the start of the K column. 

We can now use the CountIF function to see how many of the students scored 70 or 
above for a given subject. 

The CountIF function looks like this: 

COUNTIF(range, criteria) 
The function takes two arguments (the words in the round brackets). The first argument 
is range, and this means the range of cells you want Excel to count. Criteria means, "What 
do you want Excel to look for when it's counting?". 

So click inside cell K2, and then click inside the formula bar at the top. Enter the following 
formula: 

=CountIf(B2:I2, ">= 70") 
The cells B2 to I2 contain the Math scores for all 8 students. It's these scores we want to 
count. 

Press the enter key on your keyboard. Excel should give you an answer of 4: 

 

(If you're wondering where the columns B to I have gone in the image above, we've hidden 
then for convenience sake!) 

To do the rest of the scores, you can use AutoFill. You should then have a K column that 
looks like this: 
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By using CountIF, we can see at a glance which subject’s students are doing well in, and 
which subjects they are struggling in. 

Exercise Add a new label to the L column. In the cells L2 to L9, work out how many 
students got below 50 for a given subject. You should get the same results as in the image 
below: 

 

In the next part, we'll look at a function like CountIF - SumIF. 

 

4 SumIF 

Another useful Excel function is SumIF. This function is like CountIf, except it adds one 
more argument: 

SUMIF(range, criteria, sum_range) 
Range and criteria are the same as with CountIF - the range of cells to search, and what 
you want Excel to look for. The Sum_Range is like range, but it searches a new range of 
cells. To clarify all that, here's what we'll use SumIF for. (Start a new spreadsheet for this.) 
Five people have ordered goods from us. Some have paid us, but some haven't. The five 
people are Elisa, Kelly, Steven, Euan, and Holly. We'll use SumIF to calculate how much 
in total has been paid to us, and how much is still owed. 

https://www.homeandlearn.co.uk/excel2007/excel2007s6p4.html
https://www.homeandlearn.co.uk/excel2007/excel2007s6p3.html
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So in Column A, enter the names: 

 

In Column B enter how much each person owes: 

 

In Column C, enter TRUE or FALSE values. TRUE means they have paid up, and 
FALSE means they haven't: 

 

Add two more labels: Total Paid, and Still Owed. Your spreadsheet should look 
something like this one: 
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In cells B10 and B11, we'll use a SumIF function to work out how much has been paid 
in, and how much is still owed. Here's the SumIF function again: 

SUMIF(range, criteria, sum_range) 
So, the range of cells that we want to check are the True and False values in the C 
column; the criteria is whether they have paid (True); and the Sum_Range is what we 
want to add up (in the B column). 

In cell B10, then, enter the following formula: 

=SUMIF(C3:C7, TRUE, B3:B7) 
When you press the enter key, Excel should give you the answer: 
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So, 265 is has been paid in. But we told SumIF to first check the values in the cells C3 to 
C7 (range). Then we said look for a value of TRUE (criteria). Finally, we wanted the values 
in the B column adding up, if a criteria of TRUE was indeed found (sum_range). 

Exercise 
Use SumIF to work out how much is still owed. Put your answer in cell B11. 
We'll leave the subject of Conditional Logic.  

 

 

 


